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Description 

In this session, we’ll start from scratch and create a sheet metal part to generate a flat pattern, export a DXF 
cut file, and create drawings with dimensioned bend lines. Discover best practices, things to avoid, and 
practical advice. Aimed at product designers and fabricators that use sheet metal parts looking to streamline 
their workflow through Inventor. Applicable occupations are CAD Manager, Design Engineer, Industrial 
Designer, Mechanical Engineer, Structural Detailer/Fabricator. Users should have an understanding of basic 
CAD skills. 
 
Speaker 

 
 
Kelly Young 
Inventor Technical Support Autodesk 
 
Experience primarily in manufacturing and design. Began AutoCAD use in high school. Majored in Computer 
Science at Western Oregon University and transferred to Arizona State University to study Architecture, 
finishing with a degree in Design Studies. Began drafting iron doors, gates, spiral staircases, and fire & water 
features. Became an engineer at Aerospace Contacts. Managed drawings for 53 screw machines, designed 
custom fixtures, multi-step drill bits, and specialty tooling. Worked for First Impression Ironworks transferring 
them from AutoCAD to Inventor with parametric modeling and Vault revision management. Using Vault Copy 
Design led to streamlining of manufacturing, limited errors in plasma cutting, ensured proper fitment, and 
allowed customers to visualize with 3-D renderings. Took a position as Research & Development Designer at 
U-Haul International. Joined Autodesk in June, 2017 working out of Portland, Oregon. Starting role of Inventor 
Community Forum Specialist and currently Inventor Technical Support.  
  

Learning Objectives 

• Learn how to access and set up the sheet metal template for repeat use. 

• Learn how to break down each of the sheet metal features and discover advanced techniques. 

• Learn how to create flat patterns and export cut files for post processing. 

• Learn how to document and dimension the part for shop fabrication. 
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Introduction: 
Before you get started with any operations within Inventor, you should take extra care to make sure that all 
of your Settings and Templates are as you want before you start designing.  
 
This isn’t the most exciting part of the design process, but is imperative to successful use and limiting 
errors and headaches in the future.  
 
Once we get settings dialed in, we will start designing parts within the Sheet Metal environment. This is 
where you should experiment, play, explore, and research advanced techniques. We will cover the basics 
and general shapes for this course and show how to generate Flat Patterns.  
 
Moving forward, watch everything Inventor YouTube, everything. During my time as Inventor Community 
Forum Specialist I created a Collection of Screencasts showing different modeling techniques that might be 
interesting. Here is a great link repository, if you like getting into the weeds and customization here is the 
spot. And buy his book while you’re at it, I did in 2010 and have had it on my desk since. 
 
I would encourage you to get involved in the Inventor Forum, ask and answer questions. You will gain 
invaluable knowledge, confidence, and insights.  
 
When you get ready to move to the next level, download this Collection of iLogic Models for Beginners. It 
will blow your mind as to the capabilities you will be able to accomplish.  
 
Once we have an Assembly of Sheet Metal parts created we will enter the weldment environment and add 
our welds. For good measure we’ll go through a few design accelerators to get you familiar with things like 
Bolted Connection and Frame Generator.  
 
Now that we have the parts created, we need to document for our plasma technicians, press break 
operators, welders, coating finishers, and assemblers. Get to know these people in your company and 
have an active feedback loop for Quality Control. Know what tools they use and the limitations they have. 
 
You will get frustrated, take a deep breath, look for solutions. Sometimes it is best to start over. The 
program will close unexpectedly, save often, every 3 features is a good rule. You will have incorrect plasma 
outcomes, wrong bends, misaligned holes, bad weld call outs, and parts that don’t line up. The difference 
between an expert and a novice is not how many times you do this, but how frequent and if they are 
repeated. 
 
Learn from your mistakes. Take mental care in your actions and track the logic of your model. Keep it 
simple. There are design accelerators, but many times it is easier, quicker, and safer to just create a part 
and simply constrain it somewhere. Not all parts need to or should be parametric.  
 
Time management and design intent are paramount for success when using Inventor.  
 
 
  

https://www.youtube.com/results?search_query=autodesk+inventor
https://www.youtube.com/results?search_query=autodesk+inventor
https://knowledge.autodesk.com/profile/LFUXXV9MQOVBX/collections
https://knowledge.autodesk.com/profile/LFUXXV9MQOVBX/collections
http://inventortrenches.blogspot.com/p/inventor-links.html
http://inventortrenches.blogspot.com/p/inventor-links.html
https://forums.autodesk.com/t5/inventor/ct-p/70?_ga=2.37119008.1404237267.1573454812-1472265744.1536596617
https://forums.autodesk.com/t5/inventor/ct-p/70?_ga=2.37119008.1404237267.1573454812-1472265744.1536596617
https://forums.autodesk.com/t5/inventor-forum/collection-of-ilogic-models-for-beginners/td-p/7330801
https://forums.autodesk.com/t5/inventor-forum/collection-of-ilogic-models-for-beginners/td-p/7330801
https://knowledge.autodesk.com/support/inventor/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/Inventor-Help/files/GUID-5986183A-97D5-4E2D-AE00-C1AE0D1C53BB-htm.html
https://knowledge.autodesk.com/support/inventor/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/Inventor-Help/files/GUID-5986183A-97D5-4E2D-AE00-C1AE0D1C53BB-htm.html
https://knowledge.autodesk.com/support/inventor-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Inventor/files/GUID-428F9F0B-9CB7-4734-ABBC-9CA9068214BD-htm.html
https://knowledge.autodesk.com/support/inventor-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Inventor/files/GUID-428F9F0B-9CB7-4734-ABBC-9CA9068214BD-htm.html
https://knowledge.autodesk.com/support/inventor/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/Inventor-Help/files/GUID-953F560A-C2D3-4031-8348-762054C7C779-htm.html
https://knowledge.autodesk.com/support/inventor/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/Inventor-Help/files/GUID-953F560A-C2D3-4031-8348-762054C7C779-htm.html
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Chapter 1: How to access and set up the sheet metal template for repeat use. 
 
Fire up Inventor, let’s go. 
 
First thing we are going to setup the Project File so everything points to the right place. 

 
 

 
 
Select New > Single User Project > Create a custom name SheetMetal > Finish 

• If you have an existing Project that you want to use a Library from you can select it with Next.  

• I would recommend keeping the 1 setting for OldVersions in case something happens.  
o Always back up your files. You will thank me one day.  
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Make sure the settings are Saved and Active with a check mark. Select Done or Esc.  
 
Esc is your friend, you will use it often. Beware of hitting Esc instead of Apply or Save, this will happen and you 
will think you applied a setting but did not. Remember to pay attention, this will be a recurring theme. 
 

 
 
This is where you setup hotkeys. If you’ve ever used AutoCAD you are itching to set these up. The one I 
would recommend immediately is setting Project Geometry, I always set to P, but you should make this your 
own as you progress and find what you use most often. 
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Pro Tip: Set Apply Driven Dimension so the pop-up doesn’t show up. Leave it off until see it and know why it 
happens, but when you do, you’ll want to go here and turn it off.  
 
Time to get started with a New > Sheet Metal Part.ipt.  

• Be familiar with the different file types unique to Inventor: 
o Part.ipt 
o Assembly.iam 
o Drawing.idw or Drawing.dwg (AutoCAD extension that works both ways!) 
o Presentation.ipn 
o Nest.inest 
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There are multiple ways to get to New, I like the little sheet up 
top as it never goes anywhere.  
 
 
 
 
If you create a regular Part by mistake, no problem, you can 
Convert To Sheet Metal, and vise versa.  
 
 

 
 
 
 
Let’s setup the Sheet Metal Defaults.  
 
This step is critical and often overlooked. 
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New… > 1/8 Stainless 
Material = Stainless Steel. 
Thickness = 1/8 

 
 
The Bend Radius is set to Thickness by default, but you should check with your press break operator to see 
what dies are available for use. You can define them as User Parameters. 
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Depending on the outcome in the real world, after measuring the actual bend you might need to change the 
Bend Compensation. You can research K-Factor, Custom Unfold Equations, and Bend Allowance.  
 

 
 
Corner will change the bend intersection relief. Depending on the Cutter and Press Break this will vary with the 
project scope.  
 

 
Save and Close. 

https://forums.autodesk.com/t5/inventor-forum/k-factor-sheet-metal-works/td-p/2354717
https://forums.autodesk.com/t5/inventor-forum/k-factor-sheet-metal-works/td-p/2354717
https://knowledge.autodesk.com/support/inventor-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Inventor/files/GUID-7814AF4D-2C01-4357-B2EA-5FB2D27E0A76-htm.html
https://knowledge.autodesk.com/support/inventor-products/learn-explore/caas/CloudHelp/cloudhelp/2014/ENU/Inventor/files/GUID-7814AF4D-2C01-4357-B2EA-5FB2D27E0A76-htm.html
https://forums.autodesk.com/t5/inventor-forum/sheet-metal-bend-allowance/td-p/7523150
https://forums.autodesk.com/t5/inventor-forum/sheet-metal-bend-allowance/td-p/7523150
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Now that we have written the Sheet Metal Style to the library it can be used in the future.  
 

 
 
We have the settings for Stainless Steel Material and Thickness at 1/8. We can Save Copy As Template to 
ensure any new Sheet Metal part we create is set to this every time we start. 
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Chapter 2: How to break down each of the sheet metal features and discover advanced techniques. 
 
Time to start designing. 
 
Start 2D Sketch: 

Rotate the View Cube so it is oriented normally to your view. 
 

 
 
Select the Origin Center Point and draw a Rectangle without clicking a second time. 
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Type: Width=36 > Tab > Type: Length=60 > Enter 
By typing in the Parameter Name we can then reference them easily later instead of having to remember 
where dimension d12 goes to. 
 
If you have already set a dimension you can always change it or set it after the fact by typing the NAME= 
 

     
 
Finish Sketch (Top Right) or Hotkey S 

 
 
Face:  

 
This automatically chooses the active Sheet Metal Style and uses the Thickness parameter.  

• It in effect does the same thing as Extrude at a distance of Thickness.   
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Flange:

 
 
Set FLANGE_HEIGHT=1.5 
Select top edge it will flip Up, bottom edge Down. You can manually Flip Direction. 

• Use the View Cube to look at the Front View and zoom in on the bend.  

• Change the Bend Position and Height Datum to see what they control.  

• The other tabs will follow the Sheet Metal Defaults but you can override 
them here if needed. 

 
Access Parameters and Add Numeric User Parameter called GOAL set to 8in. 
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SAVE 
 
Setting up Planes is going to be a go to move for creating Offsets and known 
distances. 
 
Offset from the YZ Origin Plane at a distance GOAL/2 
 

 
Flange: 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Expand the << at bottom right.  
From: XY Origin Axis  
To: the inside wall.  
Keep the Flange height the same by using List Parameters to consume the same one as before.  
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You’ll notice this combined the edge, which is not ideal. We did this on purpose to illustrate. You can either: 

• Edit the Flange in the Browser and pick a different location for the Green Pointer. Points are able to 
be selected too. 

• In this case, let’s use the Corner Seam command. 
 

  
TIP: If you want the Gap to be smaller use GapSize/2 and it will tighten that up. Discuss with your welders the 
preferred gap size for welding. This will change depending on material thickness so setup Sheet Metal 
Defaults accordingly.  
 
Turn the Visibility of the Plane Off from the Browser or by RMB on the plane.  
 
Mirror: 
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Select the Feature(s) from the Browser or in the window. If there are multiple things going on the Browser is 
easiest.  
 
Repeat but this time use the XY Plane.  
 

 
 
This is the nice thing about symmetric parts, mirroring is easy.  
 
SAVE 
 
Section 3: How to create flat patterns and export cut files for post processing. 
 
Create Flat Pattern 
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You can RMB on the face of the Flat Pattern and Export Face As… to create a .dxf and send for cutting. This 
is the easiest and fastest way to get a quick path out to the shop. If your machines are having problems 
reading the file, save as an older version within Options... 
 

By RMB on the Flat Pattern in the Browser there are 
additional options to explore.  
 
Return to the model at top right > Go to Folded Part  
 

 
 
Now if we want to reference this part or use it for the Nesting Utility we can easily get to the Flat Pattern. 
Section 4: How to document and dimension the part for shop fabrication. 
 
SAVE. This is your mantra, keep saving after every successful endeavor. 
 
Much like the Sheet Metal Styles we setup for the Sheet Metal Template, the Drawing Template setup is 
very similar. For this class we will just stick to the out of the box settings for Font Size, Dimension Style, and 
Border setup etc. There are other tutorials for that and should be decided what your company Styles and 
Standards are going to be.  
 

https://www.youtube.com/watch?v=ZNUEyzpCSqI
https://www.youtube.com/watch?v=ZNUEyzpCSqI
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Set everything like you want through Style Editor, then Save to the Style Library.  
 

 
 
After that you can Save As > Save Copy As Template.  
 
There are multiple ways to Create a New Drawings  

• From the New icon 

• Ctrl+N 

• From the Browser RMB on the part icon > Create Drawing View which automatically loads the model 
and starts a Base View saving the step of creating one. 

 
  
 
Notice that if you can 
also access Create Nest 
and Nest Authoring 
from here as well.  
 
As long as the part is set 
to Thickness with a Flat 
Pattern, it will Nest 
easily. 
 
You can create as many 
base views as you want 
and have Projected 
Views showing Top, 
Side, Axonometric.  
 
Pro Tip: When creating 
or editing a Drawing 
View if you click the little 

bottom right button to access Custom View Orientation… to orient as 
you like and Return to set that way.  
 
 
 
 
 
 
 



18 
 

Create a new Base View > Sheet Metal View > Flat Pattern 

 

 
 
The bend lines show up as dashed, annotate the direction for the press brake with Bend.  
 

 
 
Depending on your company’s dimension standards, many use the bottom left corner as the Origin for 
inspection. The easiest way to quickly generate all dimensions is to create a Baseline Dimension.  



19 
 

 
 
Window select the entire view > RMB > Continue 
 
The available dimensions will populate in either direction you move. The origin might be in the middle of the 
part though instead of on the edge where we want it. To relocate zoom into the edge > RMB > Make Origin. 
 
Place the dimension set by clicking, RMB > Create. 
 
Repeat the process for the other direction. You now have dimensions going both directions but some of them 
you don’t really want as they are just grabbing relief lines. Select these and delete them.  
 

 
 
Select all the dimensions on a side and Arrange. It should look something like this after you tinker a bit.  

• I like putting the bend dimensions on their own sides for ease of visualization and error proofing. 
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Pro Tip: You can add text and link Model 

and User Parameters in-line with text 
Add Parameters  

 
This is helpful for adding detail notes that 
reference important dimensions. You can 
also add it to Leader Text for easy callouts.  
 
SAVE 
 
File > Export > PDF 
 
With these skills you can now create a 
Sheet Metal Part, generate a Flat Pattern, 
export a .dxf cutting path, and document for 
others to fabricate and then inspect.  
 
Time for some advanced skills and helpful 
tricks. 
 
 
 
 
Create New > Sheet Metal Part. 

 
Derive 
  
Select Body as Work Surface to use as a reference within this part, 
you will see it transparent in the preview. 
 
There isn’t anything else we need at this time, but you can expand and 
see what other things you can include. 
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Start 2D Sketch on the side surface wall. 
 
Project Geometry of the edge and Constrain the rectangle to the ends.  
 

Set the height to INSIDE_WALL_HEIGHT=4 
 
Finish Sketch. 
 
Face > Should select the geometry of the rectangle.  
 
Flange: Make sure that your press break operator’s die 
can fit within the bends otherwise it is impossible! 

 
Flange1: TOP_WIDTH=4 
Flange2: OUTSIDE_WALL_HEIGHT=12 
 
Work Plane:  
 
Select the inside edge and face, set to 
ANGLE=135 deg 
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3D Model > Start 2D Sketch > Project Cut Edges > Finish Sketch 
 

 
 
Extrude to the Plane. 
 

 
 
 
Mirror across the XY Origin Plane. 
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Turn off the Visibility of the Work Plane and Derived Surface. 
 
If you are in an Assembly it is sometimes helpful to turn Surfaces off that you forgot about:  
 

 
 
Notice the Half Section View, it is helpful when you need to get in somewhere tight. Don’t forget to turn if off 
when you’re done though, otherwise you can trip yourself up thinking it is a graphical error. 
 
SAVE – Keep saving more often, get in the habit. 
 
Time to add some holes, but we want it to be easily changeable for the future and able to stretch parametrically 
when the size changes.  
 
3D Model > Start 2D Sketch on the outer wall face.  
 
Project Geometry of the outer walls, lower edge, and upper edge. 
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• You might have to rotate the model slightly by holding Shift + Center Roll Button.  

 
 
 
Create a Point on each side, approximately placed. 
 
Dimension to the left wall and name WALL_OFFSET=2. 
 
Dimension to the lower edge, the value does not matter as long as it is in the approximate placement. 
 
Dimension to the upper edge, it will come in as a Driven Dimension (or you get a dialogue pop up). 
 
Edit the lower edge dimension. Select the upper edge dimension. This will make them equal and centered.  
 
Use Horizontal Constraint between the two Points.  
 
Dimension the right Point to the right wall. Make the 
value WALL_OFFSET or click the left wall dimension.  
 
Dimension between the Points.  

• We will access Parameters later to rename the 
Driven Dimension to something helpful.  

 
Finish Sketch. 
 
Create Hole. 
 
It will automatically select all of the Points visible.  
 
Deselect the Right Hole by holding Ctrl.  
 
Explore the Options, there are many. You can now 
save presets you use often in the top right + menu.  
 
Type: Through All.  
 
OK. SAVE 
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Access Parameters and rename the driven dimension (from between the points) to HOLE_SPAN. 
 
Pattern > Rectangular 

 
Set the Column Count to RAIL_NUMBER=12 
Set the Column Spacing to RAIL_COMPUTE=HOLE_SPAN / (11) 
 
Edit the Rectangular Pattern from the Browser.  
 
Change the Column Spacing value to HOLE_SPAN / (RAIL_NUMBER - 1) 

• We had to define the RAIL_NUMBER parameter before we can use it in the 
spacing equation.  

 
Now any time the length of the part changes, the holes will remain evenly spaced!  
 
Create Flat Pattern. 
 
Turn the ViewCube to Bottom and you will notice that there is an edge that is at an 
angle!  
 
We have illustrated this for 
things to beware of. You can 
easily make square, straight 
flanges all day, but when you 
want to get advanced shapes, 
you will run into this issue. 
Better to learn how to fix it now.  
 
Return to the modeling 
environment by  
Go To Folded Part.  
 
Modify > Unfold 
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Start 2D Sketch on the flat face. 
 
Use Project Geometry to highlight the angled 
edges on one side. Zoom in to ensure you get 
all the little remnants.  
 
Finish Sketch. 
 
Cut at distance of Thickness. 
 
Mirror the feature across XY Origin Plane. 
 
Refold. 
 
Select the same face for Stationary Reference 
and Add All Bends again. 
 
Now if we inspect the Flat Pattern there are no 
angled edges!  
 
We can safely Export Face As… to get our flat pattern.  
 
This is an example of using clean up techniques after you get the 
basic shape.  
 
File > Open > LengthWall-2.ipt 

 
Edit Sketch10 to inspect a different method of creating the Flange. 
 
The profile was drawn and Offset at Thickness depth as a 
Construction Line. The corners are set to BendRadius.  
 

There are the same angled Work Planes that we Extruded To 
before, but this time we will create as a Surface. 
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If the Field Surface Visibility is 
turned Off, we now have the Flange 
but as a thin Surface Body. 

 

3D Model > Modify > Thicken/Offset 

 

Select the Surface Body with Quilt 
at distance of Thickness.  

 

It creates a perfect Flat Pattern that 
does not need to be trimmed or 
edited!  

 

The shape is a little different than our other part though. These are the things that you will have to decide what 
you can live with, what is important, and what you can fudge to get a good end result.  

 

Pro Tip: Using the Surface Thicken at Thickness Parameter will get you out of a tough situation when you 
can’t use the Sheet Metal Tools to do what you want.  

 

The main problem people run into is when their Material Thickness does not match up to the Sheet Metal 
Defaults Thickness and the Flat Pattern will not compute.  

 

For the shorter side, we will Open WidthWall.ipt and inspect the Browser Tree to see how it was built.  

Getting familiar with inspecting parts will help you understand how things are designed.  
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Drag the End of Folded (typically shown as End of Part in non-Sheet Metal Parts) up to the top of the tree 
below the first Feature (LenghtWall.ipt Derive). 

  

Edit Derived Part. 

 

Take a look at what was 
brought in as references, 
dimensions, bodies, etc. 

 

Drag the End of Folded 
down one step. 

 

Inspect. 

 

Repeat and you will notice 
it is the same workflow we 
did for the longer side.  

 

There is no need for the rail holes, but we do need to create a ball return.  

 

Now we have the Field.ipt, LenghtWall.ipt, & WidthWall.ipt. Let’s bring them 
together in a Assembly.iam from the top left New menu.  

 

For this exercise we will be using the premade parts for ease of use.  

Component > Place > Ctrl Select multiple files at once > OK 

 

 

Click anywhere on the screen to place one set > RMB > OK 
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You should have something that looks like this: 

 

Select the Field.ipt from the screen or Browser Tree. 

 

Assemble > Productivity > Ground and Root 

 

There is an option for Create origin flush constraints, but we will leave that off, just know it is an option. 

 

Boom – it locked it down to the origin, which if you check the 
Assembly Origin Planes, should be in the middle matching 
up with the Part Origin Planes.  

 

Do the same thing with the other two parts. They should 
match up in the correct places, no constraints needed! 
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Assemble > Pattern > Mirror 

 

Select LengthWall and highlight Reuse. If you select the green button it will create a new part instead.  

Use the Assembly YZ Origin Plane, not the Part. Next > OK. 

Repeat for WidthWall along the Assembly XY Origin Plane. 
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Open > FoosballTable.iam 

 

There are Legs, BallReturn, and Braces. Each of 
these parts uses techniques that you can inspect 
and figure out what is going on by dragging the 
End of Folded up from the Browser Tree.  

 

You’ll notice the Leg and Brace have Adaptive 
symbol with the red and blue arrows is On. The 
parts were created from inside the assembly 
environment and are directly linked to the geometry 
without using Derive.  

This has advantages of being fast and easy, but 
can easily become disjointed if the model geometry 
changes too much.  

 

Personally, I use Adaptive Parts to define the shape of the model and then turn Off and break any links. 
This makes it not parametric anymore but saves headaches down the road.  

 

Pro Tip: Become more familiar with iLogic. Inspect all models at Collection of iLogic Examples For Beginners. 

 

This is advanced use of Inventor, but I wanted to show you how to access and be able to look at the code and 
see what it is doing. This is where you want to get to someday so set your goals high.  

 

The first thing is to access the Parameters of the Assembly and create User Parameters. 

 

 

 

 

https://forums.autodesk.com/t5/inventor-forum/collection-of-ilogic-models-for-beginners/td-p/7330801
https://forums.autodesk.com/t5/inventor-forum/collection-of-ilogic-models-for-beginners/td-p/7330801
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View > User Interface > iLogic  

There will be a list of 
all the Parts in the 
Assembly along with 
the Parameters, 
Constraints, and other 
useful info.  

 

If you select 
ModelParameters and 
double click on a 
Paramter at right it will populate the code below. 

 

By simply putting =Width (which is a defined User Parameter) it 
will link the Part and you can drive it from the top level 
Assembly. 
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Find the Forms Tab > RMB > Edit  

You can Shift select User Parameters and drag them to the 
Form at the right.  

There are different options to explore like Control Type: Slider 

You are now ready to drive your Parametric model. 

 

 

Click on the FOOSBALL PARAMETERS Form Button  

 

 



34 
 

Play with the Values  

 

Do not go too crazy big or small or it will break the model. Make 
small adjustments and see the updates.  

 

You can setup a Slider with limits and increment values for easy 
visualization. 

 

You now have a Foosball table parametric to any size.  

 

Taking it one step further, you could upload your model for 
Configurator360 website use and have customers customize 
on the fly, make a .pdf, image, or get a quote. 

 

See this example site:  

C360: FoosballTable AU2019 

 

Here is a preview of the interface, it is easy to use. From the 
Assembly File > Save As > Pack & Go as .zip.  

Entry the name of the top-level assembly.  

 

https://www.autodesk.com/products/configurator-360/overview
https://www.autodesk.com/products/configurator-360/overview
https://configurator360.autodesk.com/260933930940691943/dphsb0vdthch
https://configurator360.autodesk.com/260933930940691943/dphsb0vdthch
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Go To Design: 

 

The Parameters we setup with our simple iLogic code show up and we can drive the Assembly through the 
web browser! Play around, and see how it works.  
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Outputs for an Image.jpeg or Drawing.pdf or Request A Quote that is easily customizable. 

 

 

Thank you for taking the time to go through this course and I hope that it helps you understand the Sheet Metal 
Environment, learned a few advanced tips, and gets you moving forward in your career. Save often, scour the 
Internet for tutorials, get involved in the Inventor Forum, and keep inventing. 

 

Kelly Young 

Autodesk Inventor Technical Support 


